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INTRODUCTION 
 

This step-by-step guideline introduces the AI 3D Builder, a workflow designed to help users generate 3D 

models from images using AI-based tools and refine them for use in XR, web, or research environments. 

The guide focuses on accessible, practical steps, allowing Cultural Heritage professionals and content 

creators to transform 2D images into usable 3D assets without requiring advanced technical expertise. 

By following this guide, you will be able to: 

●​ Prepare images for AI-based 3D generation 

●​ Generate a 3D model using an AI tool 

●​ Clean and optimise the model in Blender 

●​ Create and apply textures 

●​ Export a final model ready for visualisation 

THIS GUIDE IS INTENDED FOR 
●​ Cultural Heritage professionals 

●​ Archivists and researchers 

●​ XR and creative professionals 

●​ Anyone interested in AI-based 3D modelling 

No programming skills are required. Basic familiarity with images and files is sufficient. 

TOOLS AND SOFTWARE USED IN THIS GUIDE 
For both 2D images and 3D models editing, any possible software can be used but this guideline will show 

the use of respectively Photopea and Blender for them, both accessible for free. 

●​ Photopea (web-based)  for image preparation and editing 

○​ Download link: https://www.photopea.com/?utm_source=homescreen  

●​ Trellis (web-based AI tool) for generating 3D models from images 

○​ Download link: https://huggingface.co/spaces/Trellis-community/Trellis 

●​ Blender (desktop application) for cleaning, editing, and exporting models 

○​ ​​https://download.blender.org/release/Blender4.2/blender-4.2.2-windows-x64.msi 

BEFORE YOU START, YOU WILL NEED 
●​ A computer (Windows, macOS, or Linux) 

●​ Internet access 

●​ Basic image files of the object you want to model 

●​ Optional materials 

○​ Multiple images of the object (recommended for better results) 

○​ High-resolution photos  
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PREPARATION OF YOUR MATERIALS AND WORKSPACE 
●​ Organise your project into folders: 

○​ Input images (original and cleaned) 

○​ AI-generated models 

○​ Blender project files 

○​ Final exported models 

●​ Ensure that: 

○​ Images clearly show the object of interest 

○​ Background elements are minimised or removable 

○​ The object is visible from different angles (if possible) 

OVERVIEW OF THE WORKFLOW 
The AI 3D Builder workflow consists of four main stages: 

1.​ Image preparation in Photopea: isolate and clean the object in images  

2.​ 3D model generation in Trellis: use AI to create the model  

3.​ Model correction in Blender: refine geometry and fix errors  

4.​ Texture preparation in Photopea  

5.​ Texturing and export in Blender: apply textures and prepare final output  

 

 

Figure 1 Overview of the workflow 
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STEP-BY-STEP GUIDELINES 
 

STEP 1: IMAGE PREPARATION (PHOTOPEA) 
The images to be provided as input to the AI Tool (Trellis) for modeling must first be specifically prepared. 

Therefore, it is necessary to ensure that the AI Tool focuses its attention exclusively on the object we wish to 

reproduce, leaving out anything superfluous or likely to generate errors (trees, vegetation, street furniture, 

etc.). 

The background must be removed, leaving only the object of interest. The tool is able to perform this 

procedure automatically; however, the background removal algorithm is not so effective in the case of 

images with many details or with excessively uniform colors. It's important to remove as many unwanted 

elements as possible to obtain a final product that requires minimal manipulation. If this isn't possible, you 

should still try to correctly cut out the object of interest, so as to provide the AI tool with its general shape. 

WHAT IS PHOTOPEA? 
Photopea is a free, browser-based image editing tool used to prepare images before processing them with 

AI tools. 

📺 WATCH THE DEMO VIA THIS LINK: IMAGE PREPARATION (PHOTOPEA) 

 

HOW TO PREPARE YOUR IMAGES? 
 

1.​ Open Photopea  

2.​ Upload your image (File → Open) 

 

Figure 2 Uploads in Photopea 
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3.​ Remove the background: 

a.​ Use the Lasso tool  

i.​ The default option is Lasso Select. To be able to select the object, the option 

Polygonal Lasso is recommended; this option can be accessed by long-pressing the 

Lasso tool and selecting Polygonal Lasso Select. 

 

Figure 3 Lasso tool​ ​ ​ ​ ​ Figure 4 Polygonal Lasso Select  

 

b.​ Once the object’s shape is defined, invert the selection: go to Select → Inverse 

i.​ The selection will now include all the objects to be deleted, except the object we're 

interested in.  

 

Figure 5 Inverse in Photopea 

c.​ To remove the unwanted items, press the DELETE button on your keyboard. 

​
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4.​ Export the image: 

a.​ File → Export As … → PNG 

The resulting images must be saved in .PNG format to preserve the transparency of the removed image 

portions. Saving in .JPG format automatically fills the deleted portions with white, which could cause 

calculation errors in the AI Tool. 

Important: Clean images significantly improve AI-generated results by reducing unwanted artefacts. 

 

Figure 6 Export path in Photopea 
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STEP 2: 3D MODEL GENERATION (TRELLIS) 
 

WHAT IS TRELLIS? 

Trellis is an AI-based web application that generates 3D models from one or more input images. To use the 

3D model generation tool, go to https://huggingface.co/spaces/Trellis-community/Trellis. The web app 

interface will open. 

 

Figure 7 Trellis web interface 

 

📺 WATCH THE DEMO VIA THIS LINK: 3D MODEL GENERATION (TRELLIS) 
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UPLOADING YOUR IMAGE(S) AND CONFIGURATION 

1.​ Open Trellis in your browser.​
 

2.​ Upload one or multiple images that need to be computed for 3D model creation. 

○​ Do this in the left upper section ‘Image prompt’ of the interface. (figure 7) 

○​ You can drag and drop images, or by uploading them from your computer. 

○​ If you opt to compute multiple images, select the Multiple images tab. Keep in mind that 

this is an experimental feature and may not always provide the expected results. 

​
Figure 8 Trellis upload screen 

3.​ Configure Generation settings: 

○​ Do this in the middle section on the left. (figure 7) 

GENERATION SETTINGS 

●​ Seed: The "seed" value establishes a random configuration for the 3D model generation.  

For the other parameters it is better to stick to the following values, so the model can be generated 

following the input images as faithfully as possible. The general guideline is that the higher the value set 

for each parameter, the less room for free interpretation by the A there will beI. 

●​ Stage 1: Sparse Structure Generation 
○​ Guidance Strength: 10 

○​ Sampling Steps: 50 

●​ Stage 2: Structured Latent Generation 
○​ Guidance Strength: 10 

○​ Sampling Steps: 50 

●​ Multi-image Algorithm: Stochastic 
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4.​ Configure GLB Extraction settings 

○​ Do this in the bottom section on the left. (figure 7) 

○​ These settings allow you to set the parameters for saving the 3D model, with the option to 

save it in .GLB or Gaussian (.PLY) format. The Gaussian PLY (Polygon File Format) is a 

technology that uses points instead of traditional polygons to represent 3D models. It 

enables a lighter, more detailed, and dynamic representation of materials, textures, and 

reflections. 

GLB EXTRACTION SETTINGS 

●​ Simplify: 0.98 
●​ Texture Size: 512 

 
Important: Depending on the degree of fidelity desired compared to the input images, the parameters are 
set accordingly: if the goal is to obtain a model that adheres as closely as possible to the input images, the 
parameters should be set to the maximum; conversely, if the AI Tool is preferred to have greater freedom of 
interpretation, the parameters can be set to intermediate values or to the minimum. 

3D MODEL CREATION AND EXPORT 

1.​ Click Generate & Extract GLB to start the model creation process. Wait for the mesh to calculate. 

2.​ The model is displayed in the Generated 3D Asset section (as a panoramic video; upper right 

section, see figure 7) and in the Extracted GLB/Gaussian section (as a real-time view; lower right 

section, see figure 7).  

3.​ Click Download GLB to export the resulting model. 

Tip: Using multiple images improves accuracy but may produce inconsistent results depending on quality. 
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STEP 3: FIXING THE 3D MODEL (BLENDER) 
​
The model calculated by the AI Tool, in most cases, never turns out as expected: there are always 

imperfections resulting from an erroneous interpretation by the AI or objects that could not be eliminated 

during the cleaning phase of the images supplied as input to the Tool. It is therefore necessary to 

manipulate the generated object in order to eliminate everything that is not necessary and leave only the 

desired object. However, often eliminating these artifacts creates gaps that must be rebuilt from scratch, 

creating vertices, edges, and faces.  

To fix the object, the 3D object manipulation software Blender is used. 

​
Figure 9 Blender web interface 

WHAT IS BLENDER? 
Blender is a free, open-source 3D software used for editing, cleaning, and optimising 3D models. 

📺 WATCH THE DEMO VIA THIS LINK: FIXING 3D MODELS (BLENDER) 

​
BASIC COMMANDS IN BLENDER 
Once installed, the software welcomes the user with an introductory screen that allows them to select the 

interface language, choose a tool preset, view recently opened files, and open the file browser to select an 

existing file. 

Key Function 

Left Mouse Button (LMB) Select an object in the scene 

SHIFT and LMB Select multiple objects 

LMB and drawing a window from left to 
right 

Select all the objects inside the selection window 

Right Mouse Button (RMB) Open the context menu 

Middle Mouse Button (MMB) Orbit View 

SHIFT and MMB Pan View 

CTRL and MMB Zoom View 
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Mouse Wheel Zoom View In or Out 

X Delete the selected item with a confirmation dialog. 

Del or Canc or Delete Delete the selected item without a confirmation dialog. 

M Merge objects/vertices/edges/faces 

TAB Switch Object/Edit Mode 

G Grab the selected object 

 

HOW TO IMPORT THE 3D MODEL? 
1.​ Delete any preexisting models in Blender before import. 

a.​ Select the existing objects while holding down SHIFT, or by clicking on the models or 

selecting them by dragging. 

b.​ Press DELETE on your keyboard. 

c.​ You are left with an empty scene with the Cartesian X (red) and Y (green) axes. 

 

Figure 10 Empty scene in Blender 

To import a model 

1.​ Click File → Import → select file type 

a.​ Models from Trellis have a .GLB extension. Choose glTF 2.0 (.glb/.gltf). 

2.​ Select your generated model and click Import glTF 2.0. 
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Figure 11 Import path in Blender 

HOW TO CLEAN THE MESH? 

Remove unwanted geometry 
1.​ Select the object.​

 

2.​ Enter Edit Mode (press TAB on keyboard). 

a.​ In Edit Mode, to the right, there are 3 buttons: the selection filter with Vertices, Edges and 
Faces respectively. 

 

Figure 12 Filters in edit mode in Blender 

b.​ These allow you to manipulate, create, and delete vertices, edges, and faces.  

3.​ Select the filter ‘vertices’. 
4.​ Select the vertices in the 3D model that need to be deleted. 

a.​ Hold down the SHIFT key on the keyboard for multiple selections. 

5.​ Press the DELETE key on the keyboard.  

a.​ This will leave gaps that will be filled in during the next step. Figure 13 below is an example 

of error deletion. 
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Figure 13 Example of error deletion 

​
 

 Grant Agreement n. 101174054​ ​ 14 

 



 

 

 

 

 

 

Close gaps 
When eliminating errors resulting from the 3D generation process, it often happens that some of the 

eliminated faces belong to the surface of the object in question. Removing the faces leaves gaps that can 

be restored without affecting the overall shape of the object.  

1.​ Select the 3D model 

2.​ Enter Edit mode 

3.​ Select Vertices filter​

 

4.​ Select the three vertices of the gap 

5.​ Press F on your keyboard to create a polygon 

6.​ Repeat for the other gaps 

Tip: When two or more vertices are too close to each other, you can merge them by pressing the M key on 

the keyboard. Pressing M opens a context menu that allows you to determine how the vertices are merged. 

 

Figure 14 Example of closing gaps in Blender 

Important: The texture will appear out of place; this is because the existing texture mapping is based on the 

mesh generated by Trellis. Once surface reconstructions are performed on the mesh, the reference to the 

existing mapping is lost. However, this isn't a problem, as the texture will be replaced later and the mapping 

will be done manually again. 
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Moving or merging vertices 
Deleting a face may also leave vertices without any connection to other vertices. Furthermore, you may 

want to reduce the number of polygons of the generated model by eliminating excessively small ones and 

reconstructing them by joining their vertices to others belonging to other polygons. It is therefore necessary 

to intervene on individual vertices. Vertices are moved as with any other object in the scene, provided you 

first enter Edit Mode. 

1.​ Select Vertices filter​

 

2.​ Move vertices 

a.​ Select the vertex you want to move 

b.​ Press the G key on your keyboard to begin the movement 

i.​ You can constrain the movement along one or more axes after pressing the move 

key: click the X, Y, Z keys on the keyboard to move the elements along a single 

Cartesian axis or SHIFT+X, Y, or Z on the keyboard to move the elements on a plane. 

3.​ Merge vertices 

a.​ Select the vertices you want to merge, by holding down SHIFT and clicking on the individual 

vertices. 

b.​ Press M (merge) on your keyboard. 

c.​ A context menu opens 

i.​ Choice a vertex merging mode  

 

Figure 15 Context menu for merging vertices 
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STEP 4: TEXTURE PREPARATION (PHOTOPEA) 

During model generation, Trellis is able to create a texture from the photos it receives as input. If only a 

single photo is provided, Trellis interprets the missing information using the database of photos used for 

training. When multiple images are provided, the AI tool attempts to interpolate all the information to meet 

the reliability parameter settings set before generation. Sometimes, however, the texture content is 

generated arbitrarily, and the resolution is not high enough to be considered optimal in most cases. It is 

therefore necessary to create a texture manually from locally available images.  

The main operations involved in creating the texture are:  

●​ compositing multiple images,  

●​ eliminating unnecessary details,  

●​ straightening to correct perspective aberration, 

●​ balancing brightness and contrast. 

📺 WATCH THE DEMO VIA THIS LINK: TEXTURES PREPARATION (PHOTOPEA) 

 

IMPORT IMAGES FOR TEXTURE 
1.​ Open Photopea 

2.​ Import images into Photopea 

a.​ Select ‘Open from computer’ 

b.​ Select the image you want to modify 

Tip: Use an image taken as close to the object as possible, so as not to lose details. 

IMAGE CLEANING 
1.​ Select the area you want to clean 

a.​ You can use Rectangular selection, Lasso selection (normal, polygonal, magnetic) or Magic 

Wand selection. 

2.​ Press DELETE on your keyboard to delete the selected area 

3.​ To fill in the empty area 

a.​ Option 1 

i.​ Right click on the selection 

ii.​ Choose ‘Fill’. It will open a dialog window to select the filling method 

iii.​ Choose ‘Content aware’ 
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Figure 16 Filling method in Photopea 

 

b.​ Option 2: the Clone tool 

i.​ Select an existing part of the image you want to copy 

ii.​ Select the Clone tool 

iii.​ Copy the content to the empty area you first cleaned. 

 

Figure 17 Clone tool in Photopea 

STRAIGHTENING FOR PERSPECTIVE ABERRATION CORRECTION 
In some cases, such as when taking a photo of a tower, the image appears distorted due to the curvature of 

the tower itself. Since it isn't a flat surface, it's not possible to use the photo as a basis for creating a texture. 

It's therefore necessary to straighten the image to obtain a "flat" image that can be used as a texture. The 

first step involves isolating a section of the photo where the shooting point is perpendicular to the surface 

of the tower. 

1.​ Use the Trim tool. 

2.​ Crop the image.  

a.​ The crop should result in an image with a 1:1 aspect ratio, preferably. 

3.​ Isolate the section deemed suitable for creating the texture. 
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Figure 18 Trim tool in Photopea​     ​          Figure 19 Crop for texture with 1:1 ratio in Photopea 

 

4.​ Now straighten the photo to obtain a flat texture 

a.​ Go to Edit → Transform → Warp tool. 

i.​ ​​The image will be surrounded by squares and dots on the edges of the image 

b.​ Drag the grips to straighten the image 

 

Figure 20 Warp tool in Photopea 
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Figure 21 Left: before straightening. Right: result after straightening in Photopea 

 

BRIGHTNESS AND CONTRAST 
The image you just obtained, may have lighter or darker areas due to shadows or uneven sunlight. This 

causes the appearance of cuts, even abrupt ones, when applying the texture to the final object. To prevent 

this behavior, the texture must be modified to make the brightness and contrast uniform. 

1.​ Go to Image → Adjustments → Brightness/Contrast…​
 

2.​ Adjust brightness and contrast ​
 

3.​ Click ‘OK’ 

 

Figure 22 Path to adjust brightness and contrast in Photopea 
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CREATE SEAMLESS TEXTURES 
In the previous step, a texture was created that can be repeated multiple times across the entire surface. 

However, this repetition can cause visible sharp cuts that break the surface's continuity, making the model 

unrealistic. To create a seamless texture from an image, you must first translate it horizontally and 

vertically to see how repetition can affect the final result. 

1.​ Go to Filter → Other → Offset…​
 

2.​ Move the image horizontally and vertically by an amount equal to half the resolution. 

a.​ To know the image resolution, go to Image → Image Size and note the resolution. 

 

Figure 23 Left: path for offset. Right: path to retrieve image size in Photopea 

 

Figure 24 Offset command in Photopea 
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By performing the Offset command, you may notice that the connection between one repetition and the 

next has discontinuities. Once you confirm the move, you must then adjust each image in the repeated 
areas, proceeding as described above in the Image Cleaning section. 

 

Figure 25 Offset command in Photopea 

Once you've fixed the seams between each repetition, you can reset the image's positioning with the Filter 
→ Other → Offset command and move the image horizontally and vertically by an amount equal to half 

the resolution in negative value. So considering the same image, you need to move it horizontally and 

vertically by -1500 pixels. 

TEXTURE EXPORT 
To export the texture, click File → Export As... → PNG 

 

Figure 26 Export path in Photopea 
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STEP 5: APPLY THE TEXTURE TO THE 3D MODEL (BLENDER) 
​
The final step involves applying the newly created texture to the model obtained previously after the mesh 

cleaning operations. The application that allows you to perform this operation is once again Blender. After 

opening a new project and deleting the default objects from the scene, you need to import the model to 

which you want to apply the texture. 

📺 WATCH THE DEMO VIA THIS LINK: APPLYING TEXTURE TO THE 3D MODEL (BLENDER) 

 

IMPORT THE 3D MODEL 
1.​ Go to ‘File’ 

2.​ Select ‘Import’ 

3.​ Select the file type 

a.​ Models output to Trellis have a .GLB extension, so you need to select glTF 2.0 (.glb/.gltf). 

4.​ Choose the desired file from your browser 

5.​ Select Import glTF 2.0. 

 

Figure 27 Import path in Blender 

MATERIAL CREATION AND TEXTURE IMPORT 
1.​ Select the Material view mode in the right sidebar 

a.​ The model generated by Trellis already has a material with an assigned texture. You can edit 

the existing material or delete it and create a new one. 

2.​ Expand the Surface section 

3.​ Click the arrow next to the Base Color entry 

a.​ Under Base Color you will see that a texture has already been assigned. This is the one 

assigned by Trellis during the 3D model generation. 

b.​ To replace it with the one created with the previous step, click the cross on the left next to 

the file name. The display will now change. 

4.​ Click ‘Open’ to open the file browser that allows you to load the texture you created in Photopea.  
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Figure 28 Material view mode in Blender​ Figure 29 Surface section in Blender 

5.​ Click ‘Open image’. 

a.​ It is immediately applied to the entire model, but not uniformly, as you can see below.  

b.​ To solve this problem, you need to perform a correct UV mapping, which is described 

further in this manual. 

 

Figure 30 Result after uploading a new texture file 

 

6.​ If your object must be opaque, set the value of the Metallic parameter to 0 (the default setting is 1). 
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APPLYING TEXTURED MATERIAL AND CORRECT POSITIONING 
​
Once you have created the material and adjusted its parameters (such as roughness, gloss, or colour), you 

can apply it either to the entire mesh or to selected parts of the model. By default, a material is assigned to 

the whole object, but this can be refined depending on your needs.  

If you only want the material to affect specific areas:  

1.​ Select the model 

2.​ Go to Edit Mode 

3.​ Use the Faces filter to select all faces you want to assign the material​

 

4.​ In the Material tab: select the desired material and click ‘Assign’. 

 

Figure 31 Assign a Material to a face 

Note: The texture will be displayed incorrectly, as it needs to be mapped, which is described in the 

next step. 

UV mapping 
UV mapping is necessary to tell Blender how to distribute the texture across the model's surfaces. When 

calculating the model, Trellis can map the texture that is generated concurrently; changing the texture 

doesn't always mean the same mapping can be used. 

Take a look at this example​
You may notice that the texture you want to assign fills each polygon randomly. Since this isn't what you're 

looking for, you need to recalculate the mapping so that the texture is applied to the entire model in an 

orderly fashion, rather than to individual polygons. 
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Figure 32 Example of a misaligned texture an a model before UV mapping 

 

For UV Mapping 

1.​ Enter Edit mode 

2.​ Set the Face filter​  

3.​ Press ‘A’ on your keyboard to select all faces 

4.​ Click right to open the context menu 

5.​ Select ‘UV Unwrap Faces’ → ‘Unwrap’ 

​​This way, the entire surface of the model is wrapped around the texture. 

 

Figure 33 Context menu for unwrapping the model 

From this point, you can intervene in two ways: 

Option 1: if the object has a complex volume 

1.​ Right click with all faces selected 

2.​ In the context menu select UV Unwrap Faces → Smart UV Project  

It cuts the mesh based on an angle threshold (angular changes in your mesh). This gives you fine 

control over how automatic seams are created. It is a good method for simple and complex 
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geometric forms, such as mechanical objects or architecture. This algorithm examines the shape of 

your object, the faces selected and their relation to one another, and creates a UV map based on 

this information and settings that you supply. 

 

 
Figure 34 Smart UV Project 

Option 2: if the object has a regular shape (cube, cylinder, sphere) 

1.​ Right click with all faces selected 

2.​ In the context menu select UV Unwrap Faces → Cube/Cylinder/Sphere Projection 

a.​ This way, a mapping already adapted to the shape is applied. 

 

Figure 35 Cube/Cylinder/Sphere Projection 

EXPORTING THE FINAL MODEL 
The final step is to export the newly created model in a format compatible with the EUreka3D-XR Project 

tools. 

1.​ Select the 3D model 

2.​ Click File → Export → glTF 2.0 (.glb/.gltf) 
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Figure 36 File export path 

 

Important: Inside the file browser it is important to expand the Include section drop-down menu and check 

the Limit to Selected Objects option, otherwise objects outside of the one of interest could be exported. 

 

Figure 37 File browser for export 
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